R.LAB data recovery

HDDScan support => HDDScan => : coyote November 08, 2011, 02:47:56 AM



: RD-Read Test results
: coyote November 08, 2011, 02:47:56 AM
I just ran the RD-Read Test for the first time, and the Report just says:
"Open Disk
Test: RD-Read

Executing
Block start at 382361600 time 64ms
Block start at 1054211328 time 73ms"

Should I understand it passed, because it didn't say there were errors?


: Re: RD-Read Test results
: Doomer November 11, 2011, 08:33:04 PM
Looks like it's still reading


: Re: RD-Read Test results
: coyote November 11, 2011, 08:46:49 PM
Looks like it's still reading
Oops, thank you very much Doomer!

Apparently I mistakenly believed (I forget, maybe the progress bar was at 100%) that the test had completed.  I'll try again.


: Re: RD-Read Test results
: coyote May 28, 2012, 09:34:37 PM
Looks like it's still reading
In the attached jpeg you can see that it reaches 100% and says "Finished".  Does that it does not mention errors mean there are no errors?


: Re: RD-Read Test results
: dmch July 04, 2012, 11:08:28 PM
In the attached jpeg you can see that it reaches 100% and says "Finished". Does that it does not mention errors mean there are no errors?
At any given time you can double-click the "RD-Read ... Finished" string you've mentioned. This will open the details window, containing speed graph, LBAs map and detailed report.


: Re: RD-Read Test results
: coyote July 05, 2012, 12:06:06 AM
Please look at the jpeg I attached to my last Comment: you'll see that I did know to double-click on that "RD-Read ... Finished" row.  The jpeg displays the Report tab I quoted in my original post, which simply says:

"Executing
Block start at XXXXXXXXXXXX time XXms"

Since Doomer replied "Looks like it's still reading", I attached the jpeg showing it says it's finished!

Please, could someone please explain how it can simultaneously be "100%...Finished" and still "Executing"?

I've heard this is a great utility, but I don't understand these results.  Thank you very much!


: Re: RD-Read Test results
: dmch July 05, 2012, 01:27:08 AM
Please look at the jpeg I attached to my last Comment:
 ...
"Executing
Block start at XXXXXXXXXXXX time XXms"
 ...
Please, could someone please explain how it can simultaneously be "100%...Finished" and still "Executing"?
Got it. I didn't realized first that the picture you've attached is related to the first post of this topic.
Actually, with the screenshot attached your initial question is much clearer.

On the screenshot read test is finished -- you can see that by looking at the blue progress bar (which shows 100%) and at the "Finished" status at two places.

And the message which confused you by saying
"Executing
Block start at XXXXXXXXXXXX time 61ms
"

is just a program log -- HDDScan puts there all the info that you may find useful:
program starts testing your drive, OK --> "Executing",
program found that block #XXXXXXXXXXXX took 61ms to read, OK --> "Block start at XXXXXXXXXXXX time 61ms"
and so on...

There may be more than one such message or there may be no of them at all, depending on the current condition of your drive.

Hope I answered your question.

P.S.
And yes, info you've got about the HDDScan is correct: utility is great :)


: Re: RD-Read Test results
: coyote July 05, 2012, 02:01:06 AM
Thank you very much, dmch!

I'm still wondering how one knows whether or not there were errors during the test.  Can I assume there were no errors because the Report tab didn't say there were errors?  Or should I be scrolling through all the blocks on the Map tab to look for blue ("Bads") blocks to show me if there were errors?

Essentially I still have my (poorly articulated, sorry) original question:  how do I know whether the drive passes the test, or has errors, please?